Arbitrary Code Execution

Affecting drupal/drupal package, versions >=7.0.0, <7.6.2 || >=8.5.0, <8.5.9 || >=8.6.0, <8.6.6

Overview

drupal/drupal is open source content management platform powering millions of websites and applications.

Affected versions of this package are vulnerable to Arbitrary Code Execution. An attacker can perform file operations on an untrusted phar:// URI because of insufficiently validated user input.

This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.

Remediation

Upgrade drupal/drupal to version 7.6.2, 8.5.9, 8.6.6 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/RL:O
Credit
Greg Knaddison of the Drupal Security Team, Sam Thomas
CVE
CVE-2019-6339
CWE
CWE-94
Snyk ID
SNYK-PHP-DRUPALDRUPAL-73650
Disclosed
16 Jan, 2019
Published
04 Feb, 2019