Remote Code Execution

Affecting drupal/drupal package, versions >=7.0.0, <7.60 || >=8.0.0, <8.5.8 || >=8.6.0, <8.6.2

high severity

Overview

drupal/drupal is an open source content management platform powering millions of websites and applications.

Affected versions of this package are vulnerable to Remote Code Execution via the DefaultMailSystem::mail() function. When sending email some variables were not being sanitized for shell arguments.

Remediation

Upgrade drupal/drupal to version 7.60, 8.5.8, 8.6.2 or higher.

References

Do your applications use this vulnerable package?

Credit
Nick Booher
CWE
CWE-611
Snyk ID
SNYK-PHP-DRUPALDRUPAL-72478
Disclosed
17 Oct, 2018
Published
22 Oct, 2018