Access Restriction Bypass

Affecting drupal/core package, versions >=7.0.0, <7.60 || >=8.0.0, <8.5.8 || >=8.6.0, <8.6.2

Overview

drupal/core is an open source content management platform powering millions of websites and applications.

Affected versions of this package are vulnerable to Access Restriction Bypass. It failed to validate a users access to use certain transitions, allowing the user to access unintended flows that they did not have permission to perform.

Remediation

Upgrade drupal/core to versions 7.60, 8.5.8, 8.6.2 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

9.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Credit
Roland Kovacsics, attilatilman
CWE
CWE-284
Snyk ID
SNYK-PHP-DRUPALCORE-72483
Disclosed
17 Oct, 2018
Published
22 Oct, 2018