Access Control Bypass

Affecting api-platform/core package, versions >=2.2.0, <2.2.10 || >=2.3.0, <2.3.6

Do your applications use this vulnerable package? Test your applications

Overview

api-platform/core builds a fully-featured hypermedia or GraphQL API in minutes.

Affected versions of this package are vulnerable to Access Control Bypass. via the GraphQL mutations.

Remediation

Upgrade api-platform/core to version 2.2.10, 2.3.6 or higher.

References

CVSS Score

4.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Unknown
CWE
CWE-284
Snyk ID
SNYK-PHP-APIPLATFORMCORE-73552
Disclosed
09 Jan, 2019
Published
20 Jan, 2019