Information Exposure

Affecting webpack-dev-server package, versions <3.1.11

Overview

webpack-dev-server Uses webpack with a development server that provides live reloading. It should be used for development only.

Affected versions of this package are vulnerable to Information Exposure. The origin of requests is not checked by the WebSocket server, which is used for HMR. A malicious user could receive the HMR message sent by the WebSocket server via a ws://127.0.0.1:8080/ connection from any origin.

Remediation

Upgrade webpack-dev-server to version 3.1.11 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
chromium1337
CVE
CVE-2018-14732
CWE
CWE-200
Snyk ID
SNYK-JS-WEBPACKDEVSERVER-72405
Disclosed
24 Jul, 2018
Published
26 Sep, 2018