Arbitrary Command Injection

Affecting ps package, versions <1.0.0

Do your applications use this vulnerable package? Test your applications

Overview

ps is A Node.js module for looking up running processes.

Affected versions of this package are vulnerable to Arbitrary Command Injection. An attacker could inject arbitrary OS commands instead of PID numbers.

Remediation

Upgrade ps to version 1.0.0 or higher.

References

CVSS Score

6.8
medium severity
  • Attack Vector
    Adjacent
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Credit
Cristian-Alexandru Staicu
CVE
CVE-2018-16460
CWE
CWE-94
Snyk ID
SNYK-JS-PS-72307
Disclosed
09 Sep, 2018
Published
09 Sep, 2018