Authentication Bypass

Affecting passport-saml package, versions <1.0.0

Overview

passport-saml is an authentication provider for Passport, the Node.js authentication library.

Affected versions of this package are vulnerable to Authentication Bypass via the SAMLRequest parameter.

Remediation

Upgrade passport-saml to version 1.0.0 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N/RL:O
Credit
cintolas
CWE
CWE-287
Snyk ID
SNYK-JS-PASSPORTSAML-72411
Disclosed
08 Mar, 2018
Published
02 Oct, 2018