Remote Code Execution (RCE)

Affecting office-converter package, ALL versions

Overview

office-converter is a node module to convert office documents into either PDF or HTML.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). Due to insufficient input validation an attacker could run arbitrary commands on the server.

Remediation

There is no fixed version for office-converter.

References

Do your applications use this vulnerable package?

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Frank Tip
CWE
CWE-94
Snyk ID
SNYK-JS-OFFICECONVERTER-173697
Disclosed
04 Jan, 2019
Published
14 Feb, 2019