Arbitrary Command Execution

Affecting kibana package, versions <5.3.13 || >=6.4.0 <6.4.3

Do your applications use this vulnerable package? Test your applications

Overview

kibana is an open source (Apache Licensed), browser-based analytics and search dashboard for Elasticsearch.

Affected versions of this package are vulnerable to Arbitrary Command Execution due to a file inclusion flaw in the Console plugin.

Remediation

Upgrade kibana to version 5.6.13, 6.4.3 or higher.

References

CVSS Score

6.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Credit
Andrej Nemec
CVE
CVE-2018-17246
CWE
CWE-94
Snyk ID
SNYK-JS-KIBANA-72628
Disclosed
23 Oct, 2018
Published
22 Nov, 2018