SQL Injection

Affecting express-cart package, versions <1.1.8

Do your applications use this vulnerable package? Test your applications

Overview

express-cart is a fully functional shopping cart built in Node.js (Express, MongoDB) with Stripe, PayPal and Authorize.net payments.

Affected versions of this package are vulnerable to SQL Injection due to a lack of user input sanitization in the login handlers. An attacker could enumerate the email address of the customers and the administrators.

Remediation

Upgrade express-cart to version 1.1.8 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
becojo
CWE
CWE-89
Snyk ID
SNYK-JS-EXPRESSCART-72404
Disclosed
11 Sep, 2018
Published
26 Sep, 2018