Information Exposure

Affecting org.jenkins-ci.main:jenkins-core artifact, versions [,2.138.2) || [2.140, 2.146)

Overview

org.jenkins-ci.main:jenkins-core is an open source automation server.

Affected versions of this package are vulnerable to Information Exposure. An attacker with Overall/Administer permission could access to the local file system to obtain credentials entered by users if the form submission could not be successfully processed.

Remediation

Upgrade org.jenkins-ci.main:jenkins-core to version 2.138.2, 2.146 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

2.9
low severity
  • Attack Vector
    Local
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
Sam Gleske
CVE
CVE-2018-1000410
CWE
CWE-200
Snyk ID
SNYK-JAVA-ORGJENKINSCIMAIN-73612
Disclosed
27 Sep, 2019
Published
09 Jan, 2019