Cryptographic Issues - Insufficient Entropy

Affecting org.apache.kafka:kafka-clients artifact, versions [2.1.0,2.1.1)

Overview

org.apache.kafka:kafka-clients is a streaming platform that can publish and subscribe to streams of records, store streams of records in a fault-tolerant durable way, and process streams of records as they occur.

Affected versions of this package are vulnerable to Cryptographic Issues - Insufficient Entropy because in the ExpiringCredentialRefreshingLogin, the number generated by Random has a low entropy therefore more predictable.

Remediation

Upgrade org.apache.kafka:kafka-clients to version 2.1.1 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

3.7
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L/RL:O
Credit
Victor Sartori
CWE
CWE-331
Snyk ID
SNYK-JAVA-ORGAPACHEKAFKA-73631
Disclosed
22 Jan, 2019
Published
22 Jan, 2019