Privilege Escalation

Affecting github.com/google/fscrypt/security package, versions <0.2.4

Do your applications use this vulnerable package? Test your applications

Overview

github.com/google/fscrypt/security is a Go tool for managing Linux filesystem encryption.

Affected versions of the package are vulnerable to Privilege Escalation. It incorrectly restored primary and supplementary group IDs to the values associated with the root user, which allowed attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).

Remediation

Upgrade github.com/google/fscrypt/security to version 0.2.4 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Credit
Unknown
CVE
CVE-2018-6558
CWE
CWE-265
Snyk ID
SNYK-GOLANG-GITHUBCOMGOOGLEFSCRYPTSECURITY-50084
Disclosed
22 Jan, 2018
Published
29 Aug, 2018