Improper Authentication

Affecting github.com/etcd-io/etcd/auth package, versions >=3.2.0 <3.2.26 || >=3.3.0 <3.3.11

Overview

github.com/etcd-io/etcd/auth is a None

Affected versions of this package are vulnerable to Improper Authentication. If an etcd client server TLS certificate contains a Common Name (CN) which matches a valid RBAC username, a remote attacker may authenticate as that user with any valid (trusted) client certificate in a REST API request to the gRPC-gateway.

Note: This is possible only when role-based access control (RBAC) is used and client-cert-auth is enabled.

Remediation

Upgrade github.com/etcd-io/etcd/auth to version 3.2.26, 3.3.11 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Credit
Matt Wheeler
CVE
CVE-2018-16886
CWE
CWE-285
Snyk ID
SNYK-GOLANG-GITHUBCOMETCDIOETCDAUTH-73512
Disclosed
03 Jan, 2019
Published
16 Jan, 2019