Cross-site Request Forgery (CSRF)

Affecting github.com/coreos/etcd/pkg/httputil package, versions <3.4

high severity

Overview

github.com/coreos/etcd/pkg/httputil is a distributed reliable key-value store for the most critical data of a distributed system.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). An attacker can set up a website that tries to send a POST request to the etcd server and modify a key. Adding a key is done with PUT so it is theoretically safe (can't PUT from an HTML form or such) but POST allows creating in-order keys that an attacker can send.

Remediation

Upgrade github.com/coreos/etcd/pkg/httputil to version 3.4 or higher.

References

Do your applications use this vulnerable package?

Credit
zelivans
CVE
CVE-2018-1098
CWE
CWE-352
Snyk ID
SNYK-GOLANG-GITHUBCOMCOREOSETCDPKGHTTPUTIL-50069
Disclosed
25 Feb, 2018
Published
26 Apr, 2018