Authentication Bypass

Affecting microsoft.aspnetcore.identity package, versions [,1.0.6), [1.1.0, 1.1.6), [2.0.0, 2.0.4), [2.1.0, 2.1.2)

high severity

Overview

microsoft.aspnetcore.identity is the membership system for building ASP.NET Core web applications, including membership, login, and user data.

Affected versions of the package are vulnerable to Authentication Bypass. The number of incorrect login attempts is not validated, as a result a malicious user could try an infinite number of authentication attempts.

Remediation

Upgrade microsoft.aspnetcore.identity to versions 1.0.6, 1.1.6, 2.0.4, 2.1.2 or higher.

References

Do your applications use this vulnerable package?

Credit
Unknown
CVE
CVE-2018-8171
CWE
CWE-592
Snyk ID
SNYK-DOTNET-MICROSOFTASPNETCOREIDENTITY-60260
Disclosed
18 Jul, 2018
Published
26 Jul, 2018