Server-side Request Forgery (SSRF)

Affecting dotnetnuke.core package, versions [,9.2.0)

high severity

Overview

dotnetnuke.core is an open source web application framework.

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF) via the DnnImageHandler class. Attackers may be able to access information about internal network resources.

Remediation

Upgrade dotnetnuke.core to version 9.2.0 or higher.

References

Do your applications use this vulnerable package?

Credit
Kurt Boberg
CVE
CVE-2017-0929
CWE
CWE-94
Snyk ID
SNYK-DOTNET-DOTNETNUKECORE-60256
Disclosed
19 Jul, 2018
Published
19 Jul, 2018